Архив рубрики: Excel

Подсчет суточной суммы

Имеем:

Дата ВНС 4-й подъём ВНС Горская
05.11.2015 0:00 456 546
05.11.2015 1:00 432 456
05.11.2015 2:00 534 564
05.11.2015 3:00 342 546
05.11.2015 4:00 342 64

Хотим сумму за каждый день:

Дата ВНС 4-й подъём ВНС Горская
1105 0,1700 0,3300
1106 0,1300 0,1000
1107 0,1100 0,0100
1108 4,4800 5,8700
1109 7,4000 3,5800
1110 4,9600 7,9400

Сначала делаем дубликат столбца дата без информации о часах и минутах: =ДЕНЬ(A1)+МЕСЯЦ(A1)*100 (диапазон)

Затем выписываем интересующие даты в новый столбец дата (критерий)

И записываем формулу суммы по условию:

=СУММЕСЛИ(Диапазон;Критерий;Диапазон суммирования)

 

 

ПОДСВЕТКА АКТИВНОЙ СТРОКИ И СТОЛБЦА

Весь программный код сосредоточен в модуле рабочей книги, чтобы включить его в свои проекты, Вам нужно сделать следующее:

  1. Создайте новую или откройте существующую рабочую книгу Excel.
  2. Переключитесь в редактор кода VBA, нажав комбинацию клавиш Alt+F11.
  3. Слева Вы должны увидеть панель «Обозреватель проектов». Если не видите — нажмите Ctrl+R.
  4. Найдите Вашу рабочую книгу в списке проектов. Она будет выглядеть как «VBAProject(название книги)».
  5. Найдите в списке компонентов проекта (в папке Microsoft Excel Objects) пункт «ЭтаКнига». Если необходимо, щелкните на плюсике рядом с названием рабочей книги — это отобразит список ее компонентов.
  6. Дважды щелкните на пункте «ЭтаКнига» или щелкните на нем правой кнопкой, а затем выберите пункт View Code (просмотреть код) в контекстном меню.
  7. Вставьте приведенный ниже код в окно просмотра кода.

А вот и полный код решения: